Systemvoraussetzungen

    Servervoraussetzungen bee.tools® 6

    Mit folgenden Voraussetzungen wurde bee.tools 6 auf einem unserer Testserver getestet. Unter Umständen sind auch andere Konfigurationen möglich, bitte fragen Sie bei abweichender Konfiguration bei uns nach.

    Server:

    Mindestanforderung: Linux-Server

    Webserver:

    Mindestanforderung: Apache, Version >= 2.2.x

    bee.tools 6 wurde mit folgenden Module auf einem unserer Testserver getestet:

    • alias.conf, alias.load
    • auth_basic.load
    • auth_digest.load
    • authn_file.load
    • authz_default.load
    • authz_groupfile.load
    • authz_host.load
    • authz_user.load
    • autoindex.conf, autoindex.load
    • cache.load
    • cgi.load
    • deflate.conf, deflate.load
    • dir.conf, dir.load
    • disk_cache.conf, disk_cache.load
    • env.load
    • expires.load
    • file_cache.load
    • headers.load
    • mem_cache.conf, mem_cache.load
    • mime.conf, mime.load
    • negotiation.conf, negotiation.load
    • php5.conf, php5.load
    • reqtimeout.conf, reqtimeout.load
    • rewrite.load
    • setenvif.conf, setenvif.load
    • status.conf, status.load
    • suexec


    bee.tools 6 wurde mit folgender Apache Konfiguration auf einem unserer Testserver getestet:

    <VirtualHost *:80>
        ServerName www.muster.de
        # Die Subdomain-Einstellungen werden im bee.tools verwaltet, deshalb wenn möglich Wildcard verwenden:
        ServerAlias *.muster.de
        ServerAdmin m.mustermann@brain-at-work.de

        DocumentRoot /web/muster/htdocs
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /web/muster/htdocs>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride Indexes AuthConfig FileInfo Limit
            Order allow,deny
            allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
        </Directory>

        ErrorLog /web/muster/log/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel error

        CustomLog /web/muster/log/access.log combined
    </VirtualHost>

    MySQL

    Mindestanforderung: Version >= 5.6.x

    bee.tools 6 wurde mit folgender Konfiguration getestet, weitere Einstellungen entsprechen der Standardinstallation.

    key_buffer        = 16M
    max_allowed_packet    = 16M
    thread_stack        = 192K
    thread_cache_size       = 8
    query_cache_limit    = 100M
    query_cache_size        = 160M

    ImageMagick

    Mindestanforderung: Version >= 6.7.7

    PHP

    Mindestanforderung: Version >= 5.6.x (Achtung: PHP 7 wurde noch nicht freigegeben!)

    bee.tools 6 wurde mit folgenden PHP 5.6 Modulen getestet:

    • 05-opcache.ini
    • 10-pdo.ini
    • 20-gd.ini
    • 20-imap.ini
    • 20-mysql.ini
    • 20-mysqli.ini
    • 20-pdo_mysql.ini
    • 20-readline.ini


    bee.tools 6 wurde mit folgenden Konfiguration getestet, weitere Einstellungen entsprechen der Standardinstallation.

    short_open_tag = Off
    asp_tags = Off
    precision = 14
    output_buffering = 4096
    max_execution_time = 30
    max_input_time = 60
    memory_limit = 128M
    post_max_size = 8M
    default_charset = "UTF-8"
    file_uploads = On
    upload_max_filesize = 2M
    max_file_uploads = 20
    allow_url_fopen = On
    allow_url_include = Off

    ; Wird nicht zwingend benötigt, reduziert jedoch die Ladezeit um ca. die Hälfte! Bitte informieren Sie alle PHP-Entwickler, wenn Sie diese Option aktiviert haben!
    [opcache]
    opcache.enable=1
    opcache.enable_cli=1
    opcache.memory_consumption=256
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=10000
    ;opcache.max_wasted_percentage=5
    opcache.use_cwd=1
    ;opcache.validate_timestamps=1
    opcache.revalidate_freq=3600
    opcache.revalidate_path=1
    opcache.save_comments=0
    ;opcache.load_comments=1
    opcache.fast_shutdown=1
    opcache.enable_file_override=1
    opcache.optimization_level=0xffffffff
    ;opcache.inherited_hack=1
    ;opcache.dups_fix=0
    opcache.blacklist_filename=*/data/securetmp/*
    ;opcache.max_file_size=0
    opcache.consistency_checks=0
    opcache.force_restart_timeout=3600
    ;opcache.log_verbosity_level=1
    ;opcache.preferred_memory_model=
    ;opcache.protect_memory=0

    Desweiteren müssen folgende Befehle über PHP aufrufbar sein:

    • convert
    • composite
    • identify
    • rm
    • tar

     

    Weitere Software, weitere Module, abweichende Konfiguration

    Je nach Projekt kann auch weitere Software, weitere Module oder eine spezielle Konfiguration benötigt werden. Bitte fragen Sie bei uns nach, ob Sie eine abgeänderte Konfiguration benötigen.

     
     

    Info & Kontakt

    Gerne senden wir Ihnen Informationsmaterial zu und stehen persönlich für Ihre Fragen zur Verfügung:

    Telefon +49 7561 98510

    Hier klicken und anrufen! +49 7561 98510

    E-Mail Anfrage starten Anfrage senden

    Sie sind hier: